



  



<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.yoursun.com/content/tncms/live/" />
<meta name="keywords" content="englewood, news, venice, news, westvillagessun, news, northport, news" />
<meta name="news_keywords" content="englewood, news, venice, news, westvillagessun, news, northport, news" />
<meta name="description" content="SARASOTA &mdash; It was a comment that went unnoticed in Tuesday&rsquo;s discussion by the Sarasota County commissioners." />
<meta name="author" content="WARREN RICHARDSON Sun Correspondent" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="google-site-verification" content="8Mu6N-Ob2Ime0-OGH82eBXdmrJ6lVQja5AEY844uXf4" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.yoursun.com/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=649%2C321" />
<meta property="og:image:width" content="649" />
<meta property="og:image:height" content="321" />
<meta property="og:title" content="Sarasota commission's affordable housing proposal, no timelines decided" />
<meta property="og:description" content="SARASOTA &mdash; It was a comment that went unnoticed in Tuesday&rsquo;s discussion by the Sarasota County commissioners." />
<meta property="og:site_name" content="Sun Newspapers" />
<meta property="og:section" content="Englewood Sun" />
<meta name="m:id" content="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" />
<meta property="tncms:ads" content="lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.1bcdd420cb36727b46f6918c7c2dbf8e.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Source+Sans+Pro:200,200i,300,300i,400,400i,600,600i,700,700i,900,900i|Source+Serif+Pro:400,600,700|Open+Sans:400,600"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.158.2"},"page":{"grid":"boxy","style":"default","path":"\/englewood","syndicated":"false","reaction":"true","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"WARREN RICHARDSON\nSun Correspondent","id":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83","app":"editorial"},"infinity_scroll":{"display":"summary_sticky_siderail","order":"next"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":304},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-18511511-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="//tags.crwdcntrl.net/c/14156/cc.js?ns=_cc14156" id="LOTCC_14156"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc14156.add('tp', 'TNNW');
		_cc14156.add('act', ' User Login');
		_cc14156.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc14156.bcp();
</script>

<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="https://api.bntech.io/js/hG2N8i7PPVy83i67XSbgbnNkVCfSM8Xr"></script>
<script>/*<![CDATA[*/ BN_Metrics.track("view") /*]]>*/</script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.85fd144868f04603b8184a52aac0096a.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.caf244e2614d000b4f73058e1c610d12.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["englewood","news","venice","news","westvillagessun","news","northport","news"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/yoursun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.36770bdfae09a8898776cd45ffd261f5.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/yoursun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/yoursun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.562ac43ab5c59b0f315e3f7aabdfac51.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/yoursun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.ad5a34b50662b1c1bbe75784aec4754c.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/yoursun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/yoursun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/yoursun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.081af6cca616fb72b0e0f36355f012f7.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [2, 1]).addSize([1200, 0], [2, 1]).build();
                gptAdSlots['ad-863738'] = googletag.defineSlot(adUnit, [[2,1]], 'ad-863738').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-863738'].setTargeting('pos', ['impact-skyline']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [2, 1]).addSize([1200, 0], [2, 1]).build();
                gptAdSlots['ad-798871'] = googletag.defineSlot(adUnit, [[2,1]], 'ad-798871').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-798871'].setTargeting('pos', ['wallpaper']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [180, 40]).addSize([1200, 0], [180, 40]).build();
                gptAdSlots['ad-798865'] = googletag.defineSlot(adUnit, [[180,40]], 'ad-798865').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-798865'].setTargeting('pos', ['weather-sponsor']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            var mapping = googletag.sizeMapping().addSize([320, 0], [2, 1]).addSize([768, 0], [2, 1]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-800063'] = googletag.defineSlot(adUnit, [[2,1]], 'ad-800063').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-800063'].setTargeting('pos', ['pencil-responsive']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [320, 50]).addSize([992, 0], [[728, 90],[970, 200]]).addSize([1200, 0], [[728, 90],[970, 200]]).build();
                gptAdSlots['ad-798867'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,200]], 'ad-798867').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-798867'].setTargeting('pos', ['leaderboard-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            var mapping = googletag.sizeMapping().addSize([320, 0], [180, 40]).addSize([768, 0], [180, 40]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-798866'] = googletag.defineSlot(adUnit, [[180,40]], 'ad-798866').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-798866'].setTargeting('pos', ['weather-sponsor']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            
                gptAdSlots['ad-829642'] = googletag.defineSlot(adUnit, [300,250], 'ad-829642').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-829642'].setTargeting('pos', ['in-story1']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            
                gptAdSlots['ad-829643'] = googletag.defineSlot(adUnit, [300,250], 'ad-829643').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-829643'].setTargeting('pos', ['in-story2']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            
                gptAdSlots['ad-829644'] = googletag.defineSlot(adUnit, [300,250], 'ad-829644').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-829644'].setTargeting('pos', ['in-story3']);
    });
 /*]]>*/</script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.waypoints.1115c65bd62165d952fac7c1b6918b2a.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/live/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.js?_dc=1580396860"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/live/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.js?_dc=1580396797"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/ads/impressions.js?_dc=1583017592"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/ads/traffic.js?_dc=1582954593"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/ads/settings.js?_dc=1567017959"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            
                gptAdSlots['ad-798874'] = googletag.defineSlot(adUnit, [300, 250], 'ad-798874').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-798874'].setTargeting('pos', ['big-1']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300, 250]).addSize([768, 0], [300, 250]).addSize([992, 0], [[300, 250], [300, 600]]).addSize([1200, 0], [[300, 250], [300, 600]]).build();
                gptAdSlots['ad-798875'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-798875').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-798875'].setTargeting('pos', ['big-2']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/yoursun.com/englewood';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300, 250], [300, 600]]).addSize([1200, 0], [[300, 250], [300, 600]]).build();
                gptAdSlots['ad-798876'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-798876').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-798876'].setTargeting('pos', ['big-3']);
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Sarasota commission's affordable housing proposal, no timelines decided | Englewood Sun | yoursun.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #000; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #fff; } .fixed-nav #main-navigation { background-color: #fff !important; } #site-top-nav-container, #site-top-nav { background-color: #444444; } #site-footer-container, #site-footer { background-color: #000; color: #fff; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #000; } .navbar-toggle .icon-bar { background-color: #000 !important; } .navbar-toggle .sr-only-show { color: #000 !important; } #site-top-nav .list-inline>li>a { color: #999; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #000; } }#site-copyright a, #site-footer a { color: #fff; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #993232; }#site-header-container{ border-bottom: 3px solid #993232; }#site-footer-container{ border-top: 3px solid #993232; } .tnt-bg-accent { background-color: #993232; } a .tnt-caret-down { color: #993232; } .block-title .block-title-inner { border-color: #993232; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #993232; } .form-control:focus { border-bottom-color: #993232; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.yoursun.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Sarasota commission's affordable housing proposal, no timelines decided | Englewood Sun | yoursun.com" href="http://www.yoursun.com/search/?f=rss&amp;t=article&amp;c=englewood&amp;l=50&amp;s=start_time&amp;sd=desc" />
<link rel="canonical" href="https://www.yoursun.com/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html" />

            
    <script defer src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            
    
        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
    <script language="javascript" type="text/javascript">
$(document).ready(function() {     

     //$('.header-search .btn-primary span ').html('GO');
     $('.new-search #site-search-652717-btn ').html('<i class="fas tnt-search" aria-hidden="true"></i>');
          
 }); 
</script>
 

        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83 section-englewood type-article infinity-summary-sticky-siderail" data-authors='[]' data-path="/englewood">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.yoursun.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.158.2&tncms.page.grid=boxy&tncms.page.style=default&tncms.page.path=%2Fenglewood&tncms.page.syndicated=false&tncms.page.reaction=true&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=WARREN+RICHARDSON%0ASun+Correspondent&tncms.asset.id=8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83&tncms.asset.app=editorial&tncms.infinity_scroll.display=summary_sticky_siderail&tncms.infinity_scroll.order=next&tncms.vendor.outbrain=Headlines+and+photo+grid&tncms.vendor.taboola=&tncms.system.render_time=304&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.google.ua=UA-18511511-1&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<img src="https://api.bntech.io/m/pixel/hG2N8i7PPVy83i67XSbgbnNkVCfSM8Xr" style='position:fixed;left:-1000px;'/>


        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-edit-container-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="asset-owner-content asset-edit-container progress hidden-print">
            <div class="progress-bar progress-bar-primary progress-bar-striped">
                <div class="asset-edit-icon pull-left hidden-sm hidden-xs"><i class="fas tnt-certificate"></i></div>
                <div class="asset-edit-message pull-left">You are the owner of this article.</div>
                <div class="asset-edit-btns pull-right">
                    <a class="btn btn-primary" href="https://www.yoursun.com/users/admin/contribute/article/?assetid=8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83&assettype=article"><i class="fas tnt-pen-square"></i> Edit Article</a>
                    
                        <a class="btn btn-danger" href="https://www.yoursun.com/users/admin/contribute/article/?from_section=/englewood"><i class="fas tnt-plus-square"></i> Add New Article</a>
                    
                </div>
                <div class="clearfix"></div>
            </div>
        </div>

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-652718" class="tncms-block"><section id="block-652718" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-652718" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-652718" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-652718-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-652718-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-652718-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-652718').submit();
        return false;
    });

    $('#site-search-652718').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-652718 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-652718 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-652718-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-795753" class="tncms-block clearfix"><ul id="block-795753" class="tnt-photo-sales-cart cart-nav nav navbar-nav navbar-right clearfix ">
        <li>
            <a href="#" class="open-cart user-control-link">
                <span class="badge-dot tnt-bg-accent cart-count" style="display:none;"></span>
                <i class="fas tnt-shopping-cart tnt-fw" aria-hidden="true"></i>
            </a>
        </li>
    </ul></div><div id="tncms-block-776882" class="tncms-block"><div id="user-menu-mobile"></div></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="  "  class="nav-link tnt-section-">  </a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-i-want-to">I want to</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="https://www.yoursun.com/englewood/"  target="_blank" rel="noopener" class="nav-link tnt-section-read-local-news">Read local news  </a>
                                </li><li>
                                    <a href="https://yoursun.newsbank.com"  target="_blank" rel="noopener" class="nav-link tnt-section-find-old-stories">Find old stories </a>
                                </li><li>
                                    <a href="/users/admin/contribute/article/"  class="nav-link tnt-section-submit-a-news-tip">Submit a News tip</a>
                                </li><li>
                                    <a href="https://www.yoursun.com/englewood/site/forms/submit_letter_to_editor_englewood/"  target="_blank" rel="noopener" class="nav-link tnt-section-write-a-letter-to-the-editor">Write a letter to the editor</a>
                                </li><li>
                                    <a href="https://www.m2oform.com/Sun/EnglewoodSub/"  target="_blank" rel="noopener" class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a href="https://circulation.sun-herald.com/login.asp"  target="_blank" rel="noopener" class="nav-link tnt-section-startstop-my-paper">Start/Stop my paper</a>
                                </li><li>
                                    <a href="https://www.yoursun.com/englewood/site/forms/englewood_sun_delivery_issues/"  target="_blank" rel="noopener" class="nav-link tnt-section-report-that-i-didn-t-get-my-paper">Report that I didn’t get my paper</a>
                                </li><li>
                                    <a href="http://englewoodsun.fl.newsmemory.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-download-mobile-app">Download mobile app</a>
                                </li><li>
                                    <a href="https://placead.sun-classifieds.com/placead/"  target="_blank" rel="noopener" class="nav-link tnt-section-place-a-classified-ad">Place a classified ad </a>
                                </li><li>
                                    <a href="/contests/"  class="nav-link tnt-section-play-contests">Play contests</a>
                                </li><li>
                                    <a href="https://www.yoursun.com/app/APG_Application_Form_9-27-18.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-work-for-sun-coast-media-groupapg">Work for Sun Coast Media Group/APG</a>
                                </li><li>
                                    <a href="https://jobs.local-jobs.monster.com/?wt.mn_n=hjnpmonstercom"  target="_blank" rel="noopener" class="nav-link tnt-section-find-a-job">Find a job</a>
                                </li><li>
                                    <a href="/coastal/entertainment/"  class="nav-link tnt-section-find-something-to-do-in-the-area">Find something to do in the area </a>
                                </li><li>
                                    <a href="/englewood/site/contacts.html"  class="nav-link tnt-section-find-staff-numbers">Find staff numbers</a>
                                </li><li>
                                    <a href="http://sunnewspapers.mycapture.com/mycapture/category.asp?CategoryID=47492"  target="_blank" rel="noopener" class="nav-link tnt-section-buy-a-photo">Buy a photo </a>
                                </li><li>
                                    <a href="https://www.yoursun.com/site/sun_history.html"  target="_blank" rel="noopener" class="nav-link tnt-section-learn-about-the-sun-newspaper-s-history">Learn about the Sun newspaper’s history </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-publications">Publications</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/arcadia/"  class="nav-link tnt-section-the-arcadian">The Arcadian</a>
                                </li><li>
                                    <a href="/charlotte/"  class="nav-link tnt-section-port-charlotte-sun">Port Charlotte Sun</a>
                                </li><li>
                                    <a href="https://veniceandenglewoodsunweekly-fl.newsmemory.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-sun-weekly">Sun Weekly</a>
                                </li><li>
                                    <a href="/englewood/"  class="nav-link tnt-section-englewood-sun">Englewood Sun </a>
                                </li><li>
                                    <a href="/coastal/health/"  class="nav-link tnt-section-feeling-fit">Feeling Fit</a>
                                </li><li>
                                    <a href="http://www.harborstyle.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-harbor-style">Harbor Style</a>
                                </li><li>
                                    <a href="/coastal/entertainment/"  class="nav-link tnt-section-go">Go!</a>
                                </li><li>
                                    <a href="/northport/"  class="nav-link tnt-section-north-port-sun">North Port Sun</a>
                                </li><li>
                                    <a href="/puntagorda/"  class="nav-link tnt-section-punta-gorda-sun">Punta Gorda Sun</a>
                                </li><li>
                                    <a href="/venice/"  class="nav-link tnt-section-venice-gondolier-sun">Venice Gondolier Sun</a>
                                </li><li>
                                    <a href="/coastal/boatingandfishing/"  class="nav-link tnt-section-waterline">Waterline</a>
                                </li><li>
                                    <a href="https://www.yoursun.com/welcome-home/"  target="_blank" rel="noopener" class="nav-link tnt-section-welcome-home">Welcome Home</a>
                                </li><li>
                                    <a href="/westvillagessun/"  class="nav-link tnt-section-west-villages-sun">West Villages Sun</a>
                                </li><li>
                                    <a href="https://desotosunweekly-fl.newsmemory.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-desoto-sun-weekly">Desoto Sun weekly</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-subscribe">Subscribe </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="https://www.m2oform.com/Sun/EnglewoodSub/"  target="_blank" rel="noopener" class="nav-link tnt-section-start-subscription">Start subscription</a>
                                </li><li>
                                    <a href="https://www.yoursun.com/site/forms/carrier_application/"  target="_blank" rel="noopener" class="nav-link tnt-section-carrier-application">Carrier application</a>
                                </li><li>
                                    <a   class="nav-link tnt-section-app-downloads">App downloads</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/classifieds/housing/"  class="nav-link tnt-section-homes-for-sale">Homes for Sale</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://autosearchflorida.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-cars-for-sale">Cars for Sale</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://www.yoursun.com/classifieds/job/"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="/marketplace/"  class="nav-link tnt-section-business-directory">Business Directory</a>
                                </li><li>
                                    <a href="https://autosearchflorida.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-cars">Cars</a>
                                </li><li>
                                    <a href="/classifieds/housing/"  class="nav-link tnt-section-homes">Homes</a>
                                </li><li>
                                    <a href="https://jobs.local-jobs.monster.com/?wt.mn_n=hjnpmonstercom"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                                </li><li>
                                    <a href="/welcomehomeflorida"  class="nav-link tnt-section-real-estate">Real Estate</a>
                                </li><li>
                                    <a href="https://placead.sun-classifieds.com/placead/"  target="_blank" rel="noopener" class="nav-link tnt-section-place-an-ad">Place an ad</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://englewoodsun.fl.newsmemory.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-e-paper">E-Paper</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="https://yoursun.newsbank.com"  target="_blank" rel="noopener" class="nav-link tnt-section-news-archives">News Archives</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://englewoodsun.fl.newsmemory.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-app">App</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://www.floridapublicnotices.com/search/"  target="_blank" rel="noopener" class="nav-link tnt-section-public-notices">Public Notices</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-14" data-target="#mobile-nav-left_menu-child-14">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-your-newspapers">Your Newspapers</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-14" class="collapse nav navbar-nav"><li>
                                    <a href="/arcadia/"  class="nav-link tnt-section-the-arcadian">The Arcadian</a>
                                </li><li>
                                    <a href="/charlotte/"  class="nav-link tnt-section-port-charlotte-sun">Port Charlotte Sun</a>
                                </li><li>
                                    <a href="https://charlotteandpuntagordasunweekly-fl.newsmemory.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-sun-weekly">Sun Weekly</a>
                                </li><li>
                                    <a href="/englewood/"  class="nav-link tnt-section-englewood-sun">Englewood Sun</a>
                                </li><li>
                                    <a href="/coastal/health/"  class="nav-link tnt-section-feeling-fit">Feeling Fit</a>
                                </li><li>
                                    <a href="harborstyle.com"  class="nav-link tnt-section-harbor-style">Harbor Style</a>
                                </li><li>
                                    <a href="/coastal/entertainment/"  class="nav-link tnt-section-go">Go!</a>
                                </li><li>
                                    <a href="/northport/"  class="nav-link tnt-section-north-port-sun">North Port Sun</a>
                                </li><li>
                                    <a href="/puntagorda/"  class="nav-link tnt-section-punta-gorda-sun">Punta Gorda Sun</a>
                                </li><li>
                                    <a href="/venice/"  class="nav-link tnt-section-venice-gondolier-sun">Venice Gondolier Sun</a>
                                </li><li>
                                    <a href="/coastal/boatingandfishing/"  class="nav-link tnt-section-waterline">Waterline</a>
                                </li><li>
                                    <a href="https://desotosunweekly-fl.newsmemory.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-desoto-sun-weekly">Desoto Sun weekly</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-15" data-target="#mobile-nav-left_menu-child-15">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-contact-us">Contact Us</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-15" class="collapse nav navbar-nav"><li>
                                    <a href="/englewood/site/contacts.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="https://www.yoursun.com/app/APG_Application_Form_9-27-18.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-employment-application">Employment Application</a>
                                </li><li>
                                    <a href="http://sunnewspapers.mycapture.com/mycapture/category.asp?CategoryID"  target="_blank" rel="noopener" class="nav-link tnt-section-purchase-photos">Purchase Photos</a>
                                </li><li>
                                    <a href="/englewood/opinion/letters_to_editor/"  class="nav-link tnt-section-submit-letter-to-the-editor">Submit Letter To The Editor</a>
                                </li><li>
                                    <a href="/users/admin/contribute/article/"  class="nav-link tnt-section-submit-a-news-tip">Submit A News Tip</a>
                                </li><li>
                                    <a href="https://www.yoursun.com/site/forms/carrier_application/"  target="_blank" rel="noopener" class="nav-link tnt-section-carrier-application">Carrier Application</a>
                                </li></ul></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-863738" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-863738" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-863738');
                        
                });
            </script>
        </div>
    </div>
</div></div>
    

    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-798871" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-798871" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-798871');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-667910" class="tncms-block"><div id="weather-667910" class="weather-current size-small pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/englewood/weather/?weather_zip=34223" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                    
                    <span class="fas tnt-wi-day-sunny"></span>
                </span>
                <span class="pull-left temp-desc small">
                    <span class="temp">62&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/englewood/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="34223"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-667910 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Englewood, FL
                                
                                 <small>(34223)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Clear skies. Low around 45F. Winds NNE at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>Clear skies. Low around 45F. Winds NNE at 5 to 10 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: February 29, 2020 @ 6:10 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/englewood/weather/?weather_zip=34223"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-798865" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-798865" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-798865');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    <div id="masthead-col-two" class="col-md-6 col-sm-6">
        <div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-779720" class="tncms-block center-image"><section id="block-779720" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/e28099d8-8bb3-11e9-9ffb-4f03cfc7bb4e.png?resize=200%2C34 200w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/e28099d8-8bb3-11e9-9ffb-4f03cfc7bb4e.png?resize=300%2C51 300w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/e28099d8-8bb3-11e9-9ffb-4f03cfc7bb4e.png?resize=400%2C69 400w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/e28099d8-8bb3-11e9-9ffb-4f03cfc7bb4e.png?resize=540%2C93 540w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/e28099d8-8bb3-11e9-9ffb-4f03cfc7bb4e.png 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
    </div>
    <div id="masthead-col-three" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-656894" class="tncms-block"><div class="follow-links-656894 pull-right">
    
    <section id="block-656894" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/EnglewoodSun" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.yoursun.com",
  "sameAs" : ["https://www.facebook.com/EnglewoodSun"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-652717" class="tncms-block new-search"><section id="block-652717" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-652717" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-652717" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal form-control">
        <input id="site-search-652717-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-652717-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-652717-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-652717').submit();
        return false;
    });

    $('#site-search-652717').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-652717 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-652717 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-652717-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-656890" class="tncms-block"><section id="block-656890" class="block emphasis-h3   " ><div class="block"><a href="/englewood/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/19425190-9344-11e9-9609-739c7c39acec.png?resize=200%2C35 200w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/19425190-9344-11e9-9609-739c7c39acec.png?resize=300%2C52 300w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/19425190-9344-11e9-9609-739c7c39acec.png 400w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-754985" class="tncms-block"><ul id="block-754985" class="tnt-photo-sales-cart cart-nav nav navbar-nav navbar-right clearfix ">
        <li>
            <a href="#" class="open-cart user-control-link">
                <span class="badge-dot tnt-bg-accent cart-count" style="display:none;"></span>
                <i class="fas tnt-shopping-cart tnt-fw" aria-hidden="true"></i>
            </a>
        </li>
    </ul></div><div id="tncms-block-776889" class="tncms-block"><style>#user-menu{position:relative;top:15px}#user-menu[data-valid="true"]{top:20px}#user-menu-mobile #user-menu{top:0;}#user-menu .nli,#user-menu[data-account-type="dsi"] .dropdown .dsi,#user-menu[data-account-type="tn"] .dropdown .tn,#user-menu[data-valid="true"] .logged-in{display:block}#user-menu .logged-in,#user-menu[data-account-type="dsi"] .dropdown .tn,#user-menu[data-account-type="tn"] .dropdown .dsi,#user-menu[data-valid="true"] .nli{display:none}#user-menu .nli{width:120px}#user-menu .nli .register{display:inline-block}#user-menu .nli .login{padding:0 0;color:#fff;font-size:12px;line-height:1.5;border:1px solid #bd837d;background:#993232;cursor:pointer}#user-menu .nli .login:hover{background:#bd837d;border:1px solid #993232}#user-menu .nli .login a{display:block;width:52px;height:28px;color:#fff;line-height:28px;text-decoration:none}#user-menu .logged-in{position:relative}#user-menu .logged-in #lidcb{display:none}#user-menu .logged-in .dr-control label{display:grid;-ms-grid-columns:1fr auto 1fr;grid-template-columns:1fr auto 1fr;font-size:12px;font-weight:700;line-height:1.5;cursor:pointer}#user-menu-mobile #user-menu .logged-in .dr-control label{color: rgba(255,255,255,.75);}#user-menu .logged-in .dr-control label .user-icon{height:18px}#user-menu .logged-in .dr-control label #screenname{padding:0 5px;max-width:75px;text-overflow:ellipsis;white-space:nowrap;overflow:hidden}#user-menu .logged-in .dr-control label:after{content:"";align-self:center;justify-self:center;width:0;height:0;border-left:4px solid transparent;border-right:4px solid transparent;border-top:4px solid #000}#user-menu-mobile #user-menu .logged-in .dr-control label:after{border-top:4px solid rgba(255,255,255,.75)}#user-menu .logged-in .dropdown{display:none;position:absolute;top:42px;right:0;min-width:160px;font-size:14px;border:0 solid #ccc;-webkit-box-shadow:5px 5px 10px 0 rgba(0,0,0,.25);-moz-box-shadow:5px 5px 10px 0 rgba(0,0,0,.25);box-shadow:5px 5px 10px 0 rgba(0,0,0,.25);background-color:#eae9e9;z-index:100}#user-menu .logged-in .dropdown .dd-header{padding:10px 25px 5px 25px;font-size:12px}#user-menu .logged-in .dropdown .dd-spacer{display:block;position:relative;width:100%;height:12px}#user-menu .logged-in .dropdown .dd-link{color:#000;text-shadow:none;padding:5px 10px;line-height:23px;font-size:16px;font-weight:700;font-family:'Open Sans'}#user-menu .logged-in .dropdown .dd-link a{color:#000;text-decoration:none}#user-menu .logged-in .dropdown .dd-link:hover{background:#000}#user-menu .logged-in .dropdown .dd-link:hover a{color:#fff}#user-menu .logged-in #lidcb:checked~.dropdown{display:block}</style><div id="user-menu-full">
    <div id="user-menu" data-valid="false" data-account-type="tn">
        <div class="nli">
            <div class="register">
                <a href="https://www.yoursun.com/users/signup/?referer_url=https%3A%2F%2Fwww.yoursun.com%2F" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a>
            </div>
            <div class="login btn btn-primary btn-sm login-btn user-control-link">
                <a href="https://login.yoursun.com?referer_url=https%3A%2F%2Fwww.yoursun.com%2F" rel="nofollow">Log In</a>
            </div>
        </div>
        <div class="logged-in">
            <input type="checkbox" id="lidcb"><div class="dr-control">
                <label for="lidcb" class="btn btn-link">
                    <img class="user-icon" src=""><span id="screenname"></span>
                </label>
            </div>
            <div class="dropdown">
                <div class="dd-header">My Account</div>
                <div class="tn">
                    <div class="dd-link">
                        <a href="https://www.yoursun.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a>
                    </div>
                    <div class="dd-link">
                        <a class="tn-user-profile-url" href="" data-app="https://www.yoursun.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a>
                    </div>
                    <div class="dd-link">
                        <a href="https://www.yoursun.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a>
                    </div>
                </div>
                <div class="dsi">
                    <div class="dd-link">
                        <a href="https://login.yoursun.com/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Register</a>
                    </div>
                </div>
                <div class="dd-spacer"></div>
                <div class="dd-link">
                    <a class="logout-btn" href="https://login.yoursun.com/logout" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a>
                </div>
            </div>
        </div>
    </div>
</div>
<script>
    BNTech.Queue('sso', function() {
        var whereIsMenu = 1;
        var pageMenu = document.querySelector('#user-menu-full');
        var navMenu = document.querySelector('#user-menu-mobile');
        
        var checkSize = function() {
            var pageWidth = Math.max(
                document.body.scrollWidth,
                document.documentElement.scrollWidth,
                document.body.offsetWidth,
                document.documentElement.offsetWidth,
                document.documentElement.clientWidth
            );

            if (pageWidth <= 990 && whereIsMenu == 1) {
                navMenu.innerHTML = pageMenu.innerHTML;
                pageMenu.innerHTML = ''
                whereIsMenu = 2;
            } else if (pageWidth > 990 && whereIsMenu == 2) {
                pageMenu.innerHTML = navMenu.innerHTML;
                navMenu.innerHTML = '';
                whereIsMenu = 1;
            }
        }

        checkSize();
        window.addEventListener('resize', checkSize);

        var menu = document.querySelector('#user-menu')
        var authToken = BNTech.Cookie.Get('tncms-authtoken');

        if (authToken != '') {
            var avatar = BNTech.Cookie.Get('tncms-avatarurl');
            var screenname = BNTech.Cookie.Get('tncms-screenname');
            menu.setAttribute('data-valid', 'true')
            menu.setAttribute('data-account-type', 'tn');
            menu.querySelector('.logged-in .user-icon').setAttribute('src', decodeURIComponent(avatar));
            menu.querySelector('.logged-in #screenname').innerHTML = screenname;
        } else if (BNTech.SSO.User.LoggedIn()) {
            var user = BNTech.SSO.User.Data();
            menu.setAttribute('data-valid', 'true')
            menu.setAttribute('data-account-type', 'dsi');
            menu.querySelector('.logged-in .user-icon').setAttribute('src', 'https://secure.gravatar.com/avatar/d271f00d72a2cb60c42fe0bdd4c82db3?s=100&d=mm&r=g');
            menu.querySelector('.logged-in #screenname').innerHTML = user.Name;
        }
    });
</script></div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link  tnt-section-home"  href="/englewood/" >
                    <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-autos"  href="http://autosearchflorida.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Autos</span>
                </a></li><li>
                <a class="nav-link  tnt-section-homes"  href="https://yoursun.com/welcomehomeflorida"  target="_blank" rel="noopener">
                    <span class="nav-label">Homes</span>
                </a></li><li>
                <a class="nav-link  tnt-section-jobs"  href="/classifieds/job/" >
                    <span class="nav-label">Jobs</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="https://www.yoursun.com/classifieds/"  target="_blank" rel="noopener">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-business-directory"  href="/marketplace/" >
                    <span class="nav-label">Business Directory</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cars"  href="https://autosearchflorida.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Cars</span>
                </a></li><li>
                <a class="nav-link  tnt-section-homes"  href="/welcomehomeflorida" >
                    <span class="nav-label">Homes</span>
                </a></li><li>
                <a class="nav-link  tnt-section-jobs"  href="https://www.yoursun.com/classifieds/job/"  target="_blank" rel="noopener">
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link  tnt-section-merchandise"  href="https://www.yoursun.com/classifieds/sale/?l=25"  target="_blank" rel="noopener">
                    <span class="nav-label">Merchandise</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pets"  href="https://www.yoursun.com/classifieds/sale/pet/?l=25"  target="_blank" rel="noopener">
                    <span class="nav-label">Pets</span>
                </a></li><li>
                <a class="nav-link  tnt-section-real-estate"  href="/welcomehomeflorida" >
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link  tnt-section-place-an-ad"  href="https://placead.sun-classifieds.com/placead/"  target="_blank" rel="noopener">
                    <span class="nav-label">Place An Ad</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-public-notices"  href="https://www.floridapublicnotices.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Public Notices</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newsletter"  href="/newsletters/" >
                    <span class="nav-label">Newsletter</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contests"  href="https://yoursun.com/contests/"  target="_blank" rel="noopener">
                    <span class="nav-label">Contests</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="https://www.m2oform.com/Sun/EnglewoodSub/"  target="_blank" rel="noopener">
                    <span class="nav-label">Subscribe</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-customer-service"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Customer Service </span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-subscribe"  href="https://www.m2oform.com/Sun/EnglewoodSub/"  target="_blank" rel="noopener">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-renew-with-ez-pay"  href="https://www.m2oform.com/Sun/EnglewoodSub/"  target="_blank" rel="noopener">
                    <span class="nav-label">Renew with EZ-Pay</span>
                </a></li><li>
                <a class="nav-link  tnt-section-verify-delivery"  href="https://www.m2oform.com/Sun/VerifyDelivery/"  target="_blank" rel="noopener">
                    <span class="nav-label">Verify Delivery</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newsletters-sign-up"  href="/englewood/newsletters/" >
                    <span class="nav-label">Newsletters Sign up</span>
                </a></li><li>
                <a class="nav-link  tnt-section-web-comments"  href="/englewood/site/forms/submit_comment_englewood" >
                    <span class="nav-label">Web Comments</span>
                </a></li><li>
                <a class="nav-link  tnt-section-create-an-online-subscription-account"  href="https://circulation.sun-herald.com/select_pub.asp"  target="_blank" rel="noopener">
                    <span class="nav-label">Create an online subscription account</span>
                </a></li><li>
                <a class="nav-link  tnt-section-access-my-subscription-account"  href="https://circulation.sun-herald.com/login.asp"  target="_blank" rel="noopener">
                    <span class="nav-label">Access my subscription account</span>
                </a></li><li>
                <a class="nav-link  tnt-section-forgot-my-account-password"  href="https://www.yoursun.com/englewood/site/forms/englewood_request_a_new_password_for_your_account/"  target="_blank" rel="noopener">
                    <span class="nav-label">Forgot my account password</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-800063" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-800063" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-800063');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-798867" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-798867" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-798867');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-685332" class="tncms-block visible-xs visible-sm"><div id="weather-685332" class="weather-current size-medium pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions ">
            <a href="/englewood/weather?weather_zip=34223" class="dropdown-toggle" >
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                    
                    <span class="fas tnt-wi-day-sunny"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">62&deg;</span>
                    
                        <span class="cond">Sunny </span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div><div id="tncms-block-798866" class="tncms-block pull-left"><div class="tnt-ads-container text-center  " >
        <div id="ad-798866" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-798866');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div><div id="modal-image-edd769fc-5b2d-11ea-9514-23f0e687559c" class="modal fullscreen in modal-image image-default modal-edd769fc-5b2d-11ea-9514-23f0e687559c" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=400%2C198"
                    srcset="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=200%2C99 200w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=300%2C148 300w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=400%2C198 400w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=540%2C267 540w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=649%2C321 750w"
                    sizes="100vw"
                    width="649"
                    height="321"
                    alt="Sarasota's affordable housing proposal, no timelines decided"
                    class="img-responsive true-size" />
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-edd769fc-5b2d-11ea-9514-23f0e687559c" data-target=".caption-inner-modal-image-edd769fc-5b2d-11ea-9514-23f0e687559c">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-edd769fc-5b2d-11ea-9514-23f0e687559c collapse in"><div class="caption-text"><p>Sarasota County could provide nonprofits the opportunity to build modestly priced housing. No timeframe had been decided.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span  class="tnt-byline">Photo Provided
<!--p:Photo credit above--></span></li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.yoursun.com%2Fsarasota-s-affordable-housing-proposal-no-timelines-decided%2Fimage_edd769fc-5b2d-11ea-9514-23f0e687559c.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sarasota-s-affordable-housing-proposal-no-timelines-decided/image_edd769fc-5b2d-11ea-9514-23f0e687559c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"edd769fc-5b2d-11ea-9514-23f0e687559c"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Sarasota%27s%20affordable%20housing%20proposal%2C%20no%20timelines%20decided&url=https%3A%2F%2Fwww.yoursun.com%2Fsarasota-s-affordable-housing-proposal-no-timelines-decided%2Fimage_edd769fc-5b2d-11ea-9514-23f0e687559c.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sarasota-s-affordable-housing-proposal-no-timelines-decided/image_edd769fc-5b2d-11ea-9514-23f0e687559c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"edd769fc-5b2d-11ea-9514-23f0e687559c"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.yoursun.com/sarasota-s-affordable-housing-proposal-no-timelines-decided/image_edd769fc-5b2d-11ea-9514-23f0e687559c.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sarasota-s-affordable-housing-proposal-no-timelines-decided/image_edd769fc-5b2d-11ea-9514-23f0e687559c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"edd769fc-5b2d-11ea-9514-23f0e687559c"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.yoursun.com/tncms/asset/editorial/edd769fc-5b2d-11ea-9514-23f0e687559c" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"edd769fc-5b2d-11ea-9514-23f0e687559c"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSun%20Coast%20Media%20Group%2C%20Inc.%5D%20Sarasota%27s%20affordable%20housing%20proposal%2C%20no%20timelines%20decided&body=https%3A%2F%2Fwww.yoursun.com%2Fsarasota-s-affordable-housing-proposal-no-timelines-decided%2Fimage_edd769fc-5b2d-11ea-9514-23f0e687559c.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"edd769fc-5b2d-11ea-9514-23f0e687559c"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sarasota-s-affordable-housing-proposal-no-timelines-decided/image_edd769fc-5b2d-11ea-9514-23f0e687559c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"edd769fc-5b2d-11ea-9514-23f0e687559c"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-edd769fc-5b2d-11ea-9514-23f0e687559c-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="edd769fc-5b2d-11ea-9514-23f0e687559c" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="edd769fc-5b2d-11ea-9514-23f0e687559c" class="save-list-edd769fc-5b2d-11ea-9514-23f0e687559c-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="edd769fc-5b2d-11ea-9514-23f0e687559c" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-edd769fc-5b2d-11ea-9514-23f0e687559c img { max-height: 321px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="asset article-default"  data-url="https://www.yoursun.com/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=649%2C321">
            <meta itemprop="width" content="649">
            <meta itemprop="height" content="321">
        </div>
        <meta itemprop="name" content="yoursun.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.yoursun.com/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html" />
    <style>
                .asset-paging .direction {
                    color: #993232;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.yoursun.com\/tncms\/search\/mlt\/?origin=8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="asset-paging">
                <div id="paging-prev-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="paging-link prev offset"></div>
                <div id="paging-next-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Sarasota commission's affordable housing proposal, no timelines decided
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span  class="tnt-byline">By WARREN RICHARDSON
Sun Correspondent
</span></li>
        
        
            <li class="visible-print">
        <time datetime="2020-02-29T16:00:00-05:00" class="tnt-date asset-date text-muted">
            Feb 29, 2020
        </time>
    </li>
            <li class="hidden-print"><time datetime="2020-02-29T16:00:00-05:00" class="tnt-date asset-date text-muted">
            Feb 29, 2020
        </time><span class="text-muted">Updated </span><time datetime="2020-02-29T17:15:42-05:00" class="tnt-date asset-date text-muted">1 hr ago</time>
    </li>
        
        
            <li class="hidden-print"><a href="/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-02-29T16:00:00-05:00">
    <meta itemprop="datePublished" content="2020-02-29T16:00:00-05:00">
    <meta itemprop="dateModified" content="2020-02-29T12:15:42-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Sarasota%20commission%27s%20affordable%20housing%20proposal%2C%20no%20timelines%20decided&url=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.yoursun.com/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.yoursun.com/tncms/asset/editorial/8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSun%20Coast%20Media%20Group%2C%20Inc.%5D%20Sarasota%20commission%27s%20affordable%20housing%20proposal%2C%20no%20timelines%20decided&body=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-edd769fc-5b2d-11ea-9514-23f0e687559c" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-edd769fc-5b2d-11ea-9514-23f0e687559c" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="649">
            <meta itemprop="height" content="321">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg">
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=400%2C198"
                    srcset="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=200%2C99 200w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=300%2C148 300w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=400%2C198 400w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=540%2C267 540w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/assets/v3/editorial/e/dd/edd769fc-5b2d-11ea-9514-23f0e687559c/5e5ac2f98edad.image.jpg?resize=649%2C321 750w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), 100vw"
                    width="649"
                    height="321"
                    alt="Sarasota's affordable housing proposal, no timelines decided"
                    class="img-responsive full tnt-restrict-img-edd769fc-5b2d-11ea-9514-23f0e687559c" />
            </div><style>
                .tnt-restrict-img-edd769fc-5b2d-11ea-9514-23f0e687559c {
                    max-width: 649px;
                }
            </style>
                
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p>Sarasota County could provide nonprofits the opportunity to build modestly priced housing. No timeframe had been decided.</p>
                            </span>
                        
                        
                            <span class="credit">
                                <span  class="tnt-byline">Photo Provided
<!--p:Photo credit above--></span>
                            </span>
                        
                    </figcaption>
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Sarasota%20commission%27s%20affordable%20housing%20proposal%2C%20no%20timelines%20decided&url=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.yoursun.com/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.yoursun.com/tncms/asset/editorial/8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSun%20Coast%20Media%20Group%2C%20Inc.%5D%20Sarasota%20commission%27s%20affordable%20housing%20proposal%2C%20no%20timelines%20decided&body=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="save-list-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>SARASOTA — It was a comment that went unnoticed in Tuesday’s discussion by the Sarasota County commissioners.</p><p>But county staff are reviewing a proposal for an affordable housing project on a county owned parcel.</p><p>Tuesday’s discussion was meant as an update for commissioners since their decision last November authorizing county Administrator Jonathan Lewis to seek applications from nonprofit organizations interested in buying surplus properties owned by the county for that same purpose.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"><div id="tncms-block-829642" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-829642" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-829642');
                        
                });
            </script>
        </div>
    </div>
</div></div><p>During his presentation, Matt Osterhoudt, director of the county’s Planning and Development Services Department, told commissioners that a property at 4644 N. Tamiami Trail in Sarasota had received interest from three nonprofits.</p><p>One of those subsequently withdrew its proposal, and from the remaining two county staff selected one, from Carrfour Supportive Housing, for further review.</p><p>Carrfour, based in Miami, has proposed purchasing the property for $1.5 million and developing a minimum of 80 mixed-income multifamily apartments on the site. Rents, according to their proposal, would range from $439 to $1,278 per month, depending on the unit.</p><p>The organization appears to have the ability to pull off a successful project.</p><p>Stephanie Berman, president and CEO of Carrfour, wrote in a cover letter to the proposal that the organization has “…provided affordable homes for more tha 10,000 Florida families,” without further elaboration.</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-829643" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-829643" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-829643');
                        
                });
            </script>
        </div>
    </div>
</div></div><p>She added that Green Mills Group, a real estate development company, would serve as a consultant and developer on the project if the county accepted the proposal.</p><p>Berman emphasized that Green Mills is “committed to building communities that improve neighborhoods …” and has “… extensive experience working closely with nonprofit organizations and local governments to develop new affordable, workforce, supportive and mixed-income communities throughout Florida.”</p><p>Osterhoudt did not indicate how long the staff review would take before it came to commissioners for their approval.</p><p>The 4644 N. Tamiami Trail property and another at 899 School Ave. S. in Sarasota had been identified by a consultant hired by the county as best suited among nine county owned properties for the development of an affordable housing project.</p><p>Commissioners asked Osterhoudt and Lewis to explore with the school board the potential of using the School Avenue property as affordable housing for teachers, something that was mentioned during a recent Convocation of Governments, Commissioner Alan Maio said.</p><p>Osterhoudt responded that he would be happy to explore that possibility.</p><p><em>Email: <a href="mailto:jondaltonwr@gmail.com">jondaltonwr@gmail.com</a></em></p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"><div id="tncms-block-829644" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-829644" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-829644');
                        
                });
            </script>
        </div>
    </div>
</div></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    
        
            
                <div id="reaction-wrap" class="reaction-wrapper hidden-print reaction-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83 anonymous">
                    <div id="reaction">
                        
                        
                        <div id="reaction-form-wrapper">
                            
                            <form id="reaction-form" onsubmit="return" data-uuid="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" method="post" action="/tncms/counter/editorial/8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83/?">
                                <input type="hidden" name="subkey" value="reaction">
                                <input type="hidden" name="action" value="add" id="action">
                                <input type="hidden" name="type" value="" id="hidden-type">
                                <input type="hidden" name="id" value="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" id="asset-id" />
                                <div class="form-icons love" data-user-reaction-emotion="love">
                                               <label class="love-icon reaction-name" data-user-reaction-emotion="love">
                                                   <span class="emotion-name" data-user-reaction-emotion="love">Love</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="love">
                                                   <div class="love-icon form-emoji" data-user-reaction-emotion="love"></div>
                                                   <div id="reaction-love-count" 
                                                        class="reaction-count count-love" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="love">0</div>
                                               </div>
                                           </div><div class="form-icons funny" data-user-reaction-emotion="funny">
                                               <label class="funny-icon reaction-name" data-user-reaction-emotion="funny">
                                                   <span class="emotion-name" data-user-reaction-emotion="funny">Funny</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="funny">
                                                   <div class="funny-icon form-emoji" data-user-reaction-emotion="funny"></div>
                                                   <div id="reaction-funny-count" 
                                                        class="reaction-count count-funny" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="funny">0</div>
                                               </div>
                                           </div><div class="form-icons wow" data-user-reaction-emotion="wow">
                                               <label class="wow-icon reaction-name" data-user-reaction-emotion="wow">
                                                   <span class="emotion-name" data-user-reaction-emotion="wow">Wow</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="wow">
                                                   <div class="wow-icon form-emoji" data-user-reaction-emotion="wow"></div>
                                                   <div id="reaction-wow-count" 
                                                        class="reaction-count count-wow" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="wow">0</div>
                                               </div>
                                           </div><div class="form-icons sad" data-user-reaction-emotion="sad">
                                               <label class="sad-icon reaction-name" data-user-reaction-emotion="sad">
                                                   <span class="emotion-name" data-user-reaction-emotion="sad">Sad</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="sad">
                                                   <div class="sad-icon form-emoji" data-user-reaction-emotion="sad"></div>
                                                   <div id="reaction-sad-count" 
                                                        class="reaction-count count-sad" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="sad">0</div>
                                               </div>
                                           </div><div class="form-icons angry" data-user-reaction-emotion="angry">
                                               <label class="angry-icon reaction-name" data-user-reaction-emotion="angry">
                                                   <span class="emotion-name" data-user-reaction-emotion="angry">Angry</span>
                                                   
                                               </label>
                                               <div class="emotion-container" data-user-reaction-emotion="angry">
                                                   <div class="angry-icon form-emoji" data-user-reaction-emotion="angry"></div>
                                                   <div id="reaction-angry-count" 
                                                        class="reaction-count count-angry" 
                                                        data-user-reaction-count="0" 
                                                        data-user-reaction-emotion="angry">0</div>
                                               </div>
                                           </div>
                            </form>
                        </div>
                    </div>
                    <div id="reaction-form-message" class="hide">
                        <p></p>
                    </div>
                </div>
        
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Sarasota%20commission%27s%20affordable%20housing%20proposal%2C%20no%20timelines%20decided&url=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.yoursun.com/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.yoursun.com/tncms/asset/editorial/8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSun%20Coast%20Media%20Group%2C%20Inc.%5D%20Sarasota%20commission%27s%20affordable%20housing%20proposal%2C%20no%20timelines%20decided&body=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" class="save-list-8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    
                        
                            <div class="asset-author">
                                
                            </div>
                        
                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-780053" class="tncms-block"><section id="block-780053" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-780053 ">
        <div class="block-title-inner">
            <h3>
                
                Recommended for you
                
            </h3>
        </div>
    </div></div><div id="card-grid-behavioral-780053" class="card-grid-behavioral card-grid card-img- card-compact"  data-lotame-track="true"><div class=" row equal equal-wrap"><div id="tncms-recommendations-780053" class="recommendations-container"></div>
            <div class="clearfix hidden-xs"></div>
            </div>
        </div></section></div></div>

                    <div class="asset-comments hidden-print"><a id="comments-collapsible-toggle" class="btn btn-block btn-lg btn-default"><i class="fas tnt-sync"></i> Load comments</a><div id="comments-collapsible" class="comments-container-collapsible collapsed">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/englewood/sarasota-commission-s-affordable-housing-proposal-no-timelines-decided/article_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.yoursun.com/users/login/?referer_url=https%3A%2F%2Fwww.yoursun.com%2Fenglewood%2Fsarasota-commission-s-affordable-housing-proposal-no-timelines-decided%2Farticle_8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div></div><div id="infinite-container" class="infinity-summary-container hidden-print">
        <div id="infinite-more" data-next-url="https://www.yoursun.com/tncms/search/mlt/?origin=8c21bfae-5a7f-11ea-9a67-6b9b08a1bf83&app=editorial&inline=infinity&type=article%2Ccollection%2Cvideo%2Cyoutube">
            <i class="fas tnt-spinner tnt-pulse"></i>
        </div>
    </div>

    <script>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</script>
    </div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-869954" class="tncms-block center-image"><section id="block-869954" class="block emphasis-h3   " ><div class="block"><a href="http://www.yoursun.com/bestofenglewood  " rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/7ddb1292-51ba-11ea-87e1-637d3d61bbf0.jpg?resize=200%2C133 200w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/7ddb1292-51ba-11ea-87e1-637d3d61bbf0.jpg 300w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="ENGLEWOOD BEST OF 2020"></a></div></section></div><div id="tncms-block-798878" class="tncms-block"><script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.yoursun.com",
  secureDomain: "www.yoursun.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div id="blox-ad-position-fixed-big-ad-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"fixed-big-ad-top","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/yoursun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":true}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-798874" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-798874" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-798874');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-867204" class="tncms-block featured-businesses"><section id="block-867204" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-867204 ">
        <div class="block-title-inner">
            <h3>
                
                Featured Businesses
                
            </h3>
        </div>
    </div></div>

    <div id="business-grid-867204" class="business-cards card-grid card-grid-multi card-slideshow  card-bg-color">
        
            
            <div class="owl-carousel-control-container text-right">
                <a class="owl-carousel-control prev btn btn-default btn-sm noselect"><span class="control-left fas tnt-chevron-left"></span></a>
                <a class="owl-carousel-control next btn btn-default btn-sm noselect"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
        
        <div class="owl-carousel  ">
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-d3bcac4b-e3f1-5aba-94dd-44614c26d818" class="clearfix card business power " data-bizid="d3bcac4b-e3f1-5aba-94dd-44614c26d818">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/the-salvation-army-family-store/business_4000097174.html" class="tnt-asset-link">
        

        
            The Salvation Army Family Store</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//1048%20Tamiami%20Trl%2BPunta%20Gorda%2BFL%2B33950">
                                        1048 Tamiami Trl, Punta Gorda, FL 33950
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-637-1981">
                                    
                                    941-637-1981
                                    
                                        </a>
                                    
                                </div>
                            </div>
    <ul class="business-tags list-inline">
    </ul>
<div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="The Salvation Army Family Store's website" href="http://www.salvationarmyflorida.org/portcharlotte/family-store" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-d62f37b2-86dc-5fff-a1e0-f3efb5d35b66" class="clearfix card business power " data-bizid="d62f37b2-86dc-5fff-a1e0-f3efb5d35b66">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/river-city-grill/business_4000097201.html" class="tnt-asset-link">
        

        
            River City Grill</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//131%20W%20Marion%20Ave%2BPunta%20Gorda%2BFL%2B34112">
                                        131 W Marion Ave, Punta Gorda, FL 34112
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-639-9080">
                                    
                                    941-639-9080
                                    
                                        </a>
                                    
                                </div>
                            <div class="card-isopen">Currently Open</div></div>
    <ul class="business-tags list-inline">
    </ul>
<div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="River City Grill's website" href="http://www.rivercitygrillpg.com/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-2d90ddd2-01a2-533c-b535-4bb3b2cfd3d4" class="clearfix card business power " data-bizid="2d90ddd2-01a2-533c-b535-4bb3b2cfd3d4">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/johnson-taylor-funeral-and-cremation/business_4000097156.html" class="tnt-asset-link">
        

        
            Johnson Taylor Funeral And Cremation</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//1515%20Tamiami%20Trl%2BPunta%20Gorda%2BFL%2B33950">
                                        1515 Tamiami Trl, Punta Gorda, FL 33950
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-833-0600">
                                    
                                    941-833-0600
                                    
                                        </a>
                                    
                                </div>
                            <div class="card-isopen">Currently Open</div></div>
    <ul class="business-tags list-inline">
    </ul>
<div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="Johnson Taylor Funeral And Cremation's website" href="http://www.johnsontaylorfuneral.com/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-d4d619c9-e907-55aa-84f3-bd07b11fd34e" class="clearfix card business power " data-bizid="d4d619c9-e907-55aa-84f3-bd07b11fd34e">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/four-points-by-sheraton-punta-gorda-harborside/business_4000097252.html" class="tnt-asset-link">
        

        
            Four Points by Sheraton Punta Gorda Harborside</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//33%20Tamiami%20Trail%2BPunta%20Gorda%2BFL%2B33950">
                                        33 Tamiami Trail, Punta Gorda, FL 33950
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-637-6770">
                                    
                                    941-637-6770
                                    
                                        </a>
                                    
                                </div>
                            <div class="card-isopen">Currently Open</div></div>
    <ul class="business-tags list-inline">
    </ul>
<div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="Four Points by Sheraton Punta Gorda Harborside's website" href="https://www.marriott.com/hotels/travel/rswfp-four-points-punta-gorda-harborside/?scid=bb1a189a-fec3-4d19-a255-54ba596febe2" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-e62006dd-39cb-5cbf-8363-c6aca953a17b" class="clearfix card business power " data-bizid="e62006dd-39cb-5cbf-8363-c6aca953a17b">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/bacon-s-furniture-design/business_4000097153.html" class="tnt-asset-link">
        

        
            Bacon's Furniture & Design</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//17701%20Murdock%20Cir%2BPort%20Charlotte%2BFL%2B33948">
                                        17701 Murdock Cir, Port Charlotte, FL 33948
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-625-4493">
                                    
                                    941-625-4493
                                    
                                        </a>
                                    
                                </div>
                            </div>
    <ul class="business-tags list-inline">
    </ul>
<div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="Bacon's Furniture &amp; Design's website" href="http://www.baconsfurniture.com/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-f62b61d3-9bce-5b6c-a340-18b6bfe02b1c" class="clearfix card business power " data-bizid="f62b61d3-9bce-5b6c-a340-18b6bfe02b1c">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/all-aboard-travel/business_4000097277.html" class="tnt-asset-link">
        

        
            All Aboard Travel</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//12530%20World%20Plaza%20Ln%2BFort%20Myers%2BFL%2B33907">
                                        12530 World Plaza Ln, Fort Myers, FL 33907
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:866-249-1087">
                                    
                                    866-249-1087
                                    
                                        </a>
                                    
                                </div>
                            </div>
    <ul class="business-tags list-inline">
    </ul>
<div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="All Aboard Travel's website" href="http://www.allaboardtravelhillsdale.com/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-735d84b3-2891-52e5-9583-d90b1440fc52" class="clearfix card business power " data-bizid="735d84b3-2891-52e5-9583-d90b1440fc52">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/arts_entertainment/museums/military-heritage-museum/business_2936924260.html" class="tnt-asset-link">
        

        
            Military Heritage Museum</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//900%20W%20Marion%20Ave%2BPunta%20Gorda%2BFL%2B33950">
                                        900 W Marion Ave, Punta Gorda, FL 33950
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-575-9002">
                                    
                                    941-575-9002
                                    
                                        </a>
                                    
                                </div>
                            </div><div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="Military Heritage Museum's website" href="https://www.militaryheritagemuseum.org/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-679c425e-7ff9-528a-9dda-8c4cd002b736" class="clearfix card business power " data-bizid="679c425e-7ff9-528a-9dda-8c4cd002b736">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/friendly-floors/business_4000097278.html" class="tnt-asset-link">
        

        
            Friendly Floors</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//3785%20Tamiami%20Trail%2BPort%20Charlotte%2BFL%2B33952">
                                        3785 Tamiami Trail, Port Charlotte, FL 33952
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-624-0077">
                                    
                                    941-624-0077
                                    
                                        </a>
                                    
                                </div>
                            </div>
    <ul class="business-tags list-inline">
    </ul>
<div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="Friendly Floors's website" href="http://www.friendlyfloors.com/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-a1adc2b0-b8d3-5158-9656-4b7beadd9db4" class="clearfix card business power " data-bizid="a1adc2b0-b8d3-5158-9656-4b7beadd9db4">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/hessler-floor-covering/business_4000097154.html" class="tnt-asset-link">
        

        
            Hessler Floor Covering</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//261%20W%20Marion%20Ave%2BPunta%20Gorda%2BFL%2B33950">
                                        261 W Marion Ave, Punta Gorda, FL 33950
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-639-2610">
                                    
                                    941-639-2610
                                    
                                        </a>
                                    
                                </div>
                            </div>
    <ul class="business-tags list-inline">
    </ul>
<div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="Hessler Floor Covering's website" href="http://www.hesslerfloors.com/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-26654a4c-f001-53ae-a0cd-ee5867114156" class="clearfix card business power " data-bizid="26654a4c-f001-53ae-a0cd-ee5867114156">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/shopping/hobby_shops/classic-creations-in-diamonds-gold/business_2936924331.html" class="tnt-asset-link">
        

        
            Classic Creations In Diamonds & Gold</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//2389%20Tamiami%20Trl%20S%2BVenice%2BFL%2B34293">
                                        2389 Tamiami Trl S, Venice, FL 34293
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-497-6331">
                                    
                                    941-497-6331
                                    
                                        </a>
                                    
                                </div>
                            </div><div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="Classic Creations In Diamonds &amp; Gold's website" href="http://classiccreationsjewelers.com/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
                
                    <div class="item ">
                        
                            <div class="card-panel panel">
                                <div class="panel-body">
                        
                        <article id="card-summary-a084aa78-e26a-5583-8373-ebcd70637c1d" class="clearfix card business power " data-bizid="a084aa78-e26a-5583-8373-ebcd70637c1d">
            <div class="card-tag">
                    <div class="tag-bg"></div>
                    <div class="tag-txt" title="Power Business" data-toggle="tooltip" data-placement="top">
                        <span class="fas tnt-star"></span>
                    </div>
                </div>
            
            <div class="card-container">
                
                <div class="card-body">
                    <div class="card-content">
                        <div class="card-headline">
                            
                            <h3 class="tnt-headline ">
        
             <a href="/marketplace/westchester-gold-diamonds/business_4000097222.html" class="tnt-asset-link">
        

        
            Westchester Gold & Diamonds</a></h3>
                        </div>
                        <div class="card-contact "><div class="card-location">
                                    <a href="https://www.google.com/maps/dir//4200%20Tamiami%20Trail%20F%2BPort%20Charlotte%2BFL%2B33952">
                                        4200 Tamiami Trail F, Port Charlotte, FL 33952
                                    </a>
                                </div>
                                <div class="card-phone">
                                    <i class="fas tnt-phone-square"></i>
                                    
                                        <a href="tel:941-625-0666">
                                    
                                    941-625-0666
                                    
                                        </a>
                                    
                                </div>
                            </div>
    <ul class="business-tags list-inline">
    </ul>
<div class="card-classifieds-links">
            <ul class="list-inline hidden-print icon"><li>
                        <a rel="nofollow" title="Westchester Gold &amp; Diamonds's website" href="http://www.westchestergold.com/" target="_blank">
                            <i class="fas tnt-globe tnt-fw" aria-hidden="true"></i> <span class="hidden-xs">Website</span>
                        </a>
                    </li></ul>
        </div>
                    </div>
                </div>
            </div>
        </article>
                        
                                </div>
                            </div>
                        
                    </div>
                    

                    

                
            
            
        </div>
    </div>

    

    
        <div class="business-cards-search panel panel-default">
          <div class="panel-heading"><h3 class="panel-title">Find a local business</h3></div>
          <div class="panel-body">
            <form class="business-search-form" action="/marketplace/" method="GET" role="form">
                <input type="hidden" name="action" value="srch">
                <input type="hidden" name="limit" value="10">
                <input type="hidden" name="sort" value="geodist">
                <input type="submit" class="hide" value="Search"><div class="input-group">
                    <input name="keyword" type="text" title="Search" class="business-search-term form-control" placeholder="I'm looking for&hellip;" value="">
                    <span class="input-group-btn">
                        <button class="business-search-submit btn btn-primary" aria-label="search_submit" type="submit">
                            <span class="fas tnt-search"></span><span class="hidden-xs hidden-sm"></span>
                        </button>
                    </span>
                </div>
            </form>
          </div>
        </div>
    </section>

    
        <script>
            $(window).load(function() {

                var bizTracked = [];
                var isUserAction = false;

                function trackActive(owl){
                    if( bizTracked.length == 11 ){
                        return;
                    }else{
                        var activeThings = $(owl).find('.owl-item.active');

                        $.each(activeThings, function(index, value){
                            var bizId = $(this).find('.card').data('bizid');
                            var hasBeenLogged = false;

                            bizTracked.forEach(function (item, index, array) {
                                if(item == bizId){
                                    hasBeenLogged = true;
                                    return true;
                                }
                            });
                            if( hasBeenLogged == false ){
                                bizTracked.push(bizId);
                                TNCMS.Tracking.addEvent({
                                    app: 'business',
                                    metric: 'block',
                                    id: bizId
                                });
                            }
                        });
                    }
                }

                window.card_carousel_867204 = $('#block-867204 .owl-carousel');

                card_carousel_867204.on('initialized.owl.carousel', function(e){
                        trackActive(card_carousel_867204);
                    });
                

                card_carousel_867204.owlCarousel({
                    loop:true,
                    margin:15,
                    nav:false,
                    dots:false,
                    slideBy: 'page',
                    autoHeight:false,
                    responsiveClass:true,
                    responsive:{
                        0:{
                            items:1,
                            stagePadding: 40,
                            nav:false
                        },
                        600:{
                            items:4
                        },
                        1000:{
                            items:2
                        }
                    }
                });

                // bind previous click
                $('#block-867204 .owl-carousel-control.prev').on(__tnt.client.clickEvent, function(e){
                    e.stopPropagation();
                    card_carousel_867204.trigger('prev.owl.carousel');

                    isUserAction = true;
                    trackActive(card_carousel_867204);
                });

                // bind next click
                $('#block-867204 .owl-carousel-control.next').on(__tnt.client.clickEvent, function(e){
                    e.stopPropagation();
                    card_carousel_867204.trigger('next.owl.carousel');

                    isUserAction = true;
                    trackActive(card_carousel_867204);
                });

                // bind dragged
                card_carousel_867204.on('dragged.owl.carousel', function(event){
                    isUserAction = true;
                    trackActive(card_carousel_867204);
                });

                // bind translated
                card_carousel_867204.on('translated.owl.carousel', function(event){
                    if( isUserAction ){
                        trackActive(card_carousel_867204);
                        isUserAction = false;
                    }
                });
            });
        </script>
    </div><div id="tncms-block-831184" class="tncms-block"><div style="text-align: center;margin-bottom: 40px;">
<div data-cswidget="9549"></div>
<script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js"> </script></div></div><div id="tncms-block-798875" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-798875" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-798875');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-671832" class="tncms-block"><div id="tncms-block" class="tncms-block">

<section id="block" class="block emphasis-h3"><div class="clearfix">   
        <div class="block-title">
            <div class="block-title-inner">
                <h3><a href="http://englewoodsun.fl.newsmemory.com/">Latest e-Edition</a></h3>
            </div>
        </div>
    </div>
    <article class="clearfix card summary"><div class="card-container">
        
                        <div class="card-image">
                            <div class="media-preview edition-asset" data-aspect="">
                                <figure class="photo layout-vertical"><div class="image">
                                    <a href="http://englewoodsun.fl.newsmemory.com/" class="tnt-asset-link">  <img src="https://englewoodsun-fl.newsmemory.com/getprima.php" alt="Englewood Sun" class="img-responsive full lazyautosizes lazyloaded" width="300" height="388" sizes="144px"></a>
                                    </div>
                                </figure>
</div>
                        </div>
                        
                    <div class="card-body" style="float: right; width: 55%;">
                        <div class="card-headline">
                            <h3 class="tnt-headline"><a href="http://englewoodsun.fl.newsmemory.com/" class="tnt-asset-link">Englewood Sun</a></h3>
                        </div>
                            <div class="card-meta" style="display: block;">
                                <ul class="list-inline">
<li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                </ul>
</div>
                    </div>
                    
        </div>
        <div class="clearfix"></div>
	</article></section>
</div></div><div id="tncms-block-731107" class="tncms-block"><p></p>
<h2>NASCAR Standings</h2></div><div id="tncms-block-731108" class="tncms-block"><div id="ap_widget_container_8179f71ef1eaf5953e17f940c5849245"></div>
<script src="https://digitalservices.ap.org/widget-content/8179f71ef1eaf5953e17f940c5849245"></script></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-798876" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-798876" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-798876');
                        
                });
            </script>
        </div>
    </div>
</div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-652710" class="tncms-block"><section id="block-652710" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-652710 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-home"  href="/englewood/" >
                    <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/englewood/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/englewood/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-ae"  href="/coastal/entertainment/" >
                    <span class="nav-label">A&E</span>
                </a></li><li>
                <a class="nav-link  tnt-section-business"  href="/englewood/business/" >
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link  tnt-section-perspectives"  href="/englewood/opinion/" >
                    <span class="nav-label">Perspectives</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="http://www.legacy.com/obituaries/englewood/"  target="_blank" rel="noopener">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-announcements"  href="/englewood/announcements/" >
                    <span class="nav-label">Announcements</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="/englewood/eedition/" >
                    <span class="nav-label">e-Edition</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="/online_features/" >
                    <span class="nav-label">Online Features</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-652661" class="tncms-block"><section id="block-652661" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-652661 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-subscription-services"  href="/site/forms/subscription_services/" >
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submission-forms"  href="/englewood/site/forms/" >
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-email-alerts"  href="/users/admin/mailinglist" >
                    <span class="nav-label">Email Alerts</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/search/" >
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/englewood/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-652711" class="tncms-block"><section id="block-652711" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-652711 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div></section></div><div id="tncms-block-656891" class="tncms-block padding-bottom"><section id="block-656891" class="block emphasis-h3   " ><div class="block"><a href="/englewood/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/816a77b4-92ba-11e9-8c03-2fa6d4f365eb.png?resize=200%2C70 200w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/816a77b4-92ba-11e9-8c03-2fa6d4f365eb.png?resize=300%2C105 300w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/816a77b4-92ba-11e9-8c03-2fa6d4f365eb.png?resize=400%2C141 400w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/816a77b4-92ba-11e9-8c03-2fa6d4f365eb.png?resize=540%2C190 540w, https://bloximages.newyork1.vip.townnews.com/yoursun.com/content/tncms/custom/image/816a77b4-92ba-11e9-8c03-2fa6d4f365eb.png 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-656892" class="tncms-block"><section id="block-656892" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-656892 ">
        <div class="block-title-inner">
            <h4>
                
                For Subscriptions, Billing &amp; Classifieds
                
            </h4>
        </div>
    </div></div><address>
    <strong>Englewood Sun</strong><br>
    23170 Harborview Road<br>
    Port Charlotte, FL 33980
    <br>
    
        <strong>Phone:</strong> 941-206-1300<br>
        <strong>Email:</strong> <a href="mailto:custserv@sun-herald.com">custserv@sun-herald.com</a><br>
    
</address></section></div><div id="tncms-block-828802" class="tncms-block"><section id="block-828802" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-828802 ">
        <div class="block-title-inner">
            <h4>
                
                For News and Display Advertising
                
            </h4>
        </div>
    </div></div><address>
    <strong>Englewood Sun</strong><br>
    120 W. Dearborn St<br>
    Englewood , FL 34223
    <br>
    
        <strong>Phone:</strong> 941-206-1300<br>
        <strong>Email:</strong> <a href="mailto:custserv@sun-herald.com">custserv@sun-herald.com</a><br>
    
</address></section></div><div id="tncms-block-656893" class="tncms-block padding-bottom"><div class="follow-links-656893 default">
    
    <section id="block-656893" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-656893 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/EnglewoodSun" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.yoursun.com",
  "sameAs" : ["https://www.facebook.com/EnglewoodSun"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-652665" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-652665"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">Sun Coast Media Group, Inc.</a>, 200 East Venice Ave. Venice, FL</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                	_cc14156.add('act', dmpData);
	_cc14156.bcp();

            });
        });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.b419cb3c218ef0da9fa281dd92729a83.js"></script>
<script src="https://az412349.vo.msecnd.net/pio/pio.latest.v2.js"></script>
<script>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</script>
<script>/*<![CDATA[*/ 
    document.addEventListener("DOMContentLoaded", function() {
        updateCartCount();
        var cartLinks = document.querySelectorAll("a.open-cart");
        for (i = 0; i < cartLinks.length; i++) {
            cartLinks[i].addEventListener("click", function (e) {
                e.preventDefault();
                gooten_photo_collection.unshift( "data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII=");
                PIO.open({ 
                    goTo: "cart",
                    images: gooten_photo_collection
                });
                document.getElementById("__pio").src = "https://widget.print.io/widget/b4309023-78ee-487b-9112-58da8835bacb/";
            });
        }
    }); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.68c227e3abfb699cd23b4f569cb997f4.js"></script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.reactions.496ef4077c989f2b546ccbd9a5d4e1f9.js"></script>
<script>/*<![CDATA[*/ 
                        function dmpReactionData(){
                            var sReactionData = document.getElementById('hidden-type').value,
                                sReactionKeywords = "";	_cc14156.add('act', sReactionData, sReactionKeywords);
	_cc14156.bcp();
} /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/withinviewport.1f94ee79a22e6ee8e9c0bb61dec9999b.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.withinviewport.6ef0fee1774e9b313c264a5736522e35.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.scrollstop.934c2bd4d6bebe0494bcb9dd4b1b6ca1.js"></script>
<script>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</script>
<script>/*<![CDATA[*/ $("#comments-collapsible-toggle").click(function() { $("#comments-collapsible, #comments-collapsible-toggle").toggleClass("collapsed"); }); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/yoursun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.66c591eb93f177b0f59892f361c3b1b4.js"></script>
<script>/*<![CDATA[*/ 
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        	_cc14156.add('act', dmpData);
	_cc14156.bcp();

                    }
                }
            }
         /*]]>*/</script></body>
</html>